Page 1 of 1

Desperate for some advice

Posted: Sat Mar 14, 2020 3:21 am
by nikonwalker
Hi,
I have the asteroid and its a great machine , I use it about 3-4 times per week.
I used it last night without any issues.
I went to turn it on today and it said y axis limit switch error , its was not at its limit but I couldnt get it to work.
Checked out the wiki page and did as suggested , cleaned terminals and used multimeter to make sure the operation of the limit switches was correct, they were.
Now the error messages of all axis shows when I turn the machine on.
If I say home machine the z axis dives down for the table and you have to hit the emergency stop quickly.
I even updated the software from wiki.
I just cant work out what went wrong , dont know where to start looking.
Hope someone can help

Terry

Re: Desperate for some advice

Posted: Sun Mar 15, 2020 11:56 pm
by 4DThinker
Check the parallel cable. All signals from the PC to the controller go down that cable. If it is loose even a bit on either end and one or more lines are not connected it'll cause problems like you've experienced. You should also make sure all the cables from the CNC are well connected to the controller.

Limit switch errors can also be from switches that aren't hooked up right. Wires to the Y axis double switches need to be connected to the outer terminals. Double check that. I once had a mystery caused by a painter who moved a CNC so he could get to the wall behind it accidently pull a wire off a Y switch. He realize it, but plugged it into the wrong terminal on the switch. That machine, which had run perfectly the day before suddenly acted like it was possessed.

If nothing looks loose, and all the switches are connected properly, a call to support at Probotix is likely your best option.

Good luck. I know from experience how frustrated you must feel.

4D

Re: Desperate for some advice

Posted: Mon Mar 16, 2020 12:06 am
by nikonwalker
I would try probotix support but they sent me an email a while ago saying support costs $500 per hour , thats out of my leaugue, thats why i try the forum

Re: Desperate for some advice

Posted: Mon Mar 16, 2020 12:09 am
by 4DThinker
That must be a new policy as I've never had them charge me or mention a change when I've contacted them. In any case check all the cable. If they all seem tight, you might unhook and check continuity end to end on every pin.

4D

Re: Desperate for some advice

Posted: Mon Mar 16, 2020 12:21 am
by nikonwalker
Thank you , I will do all you suggested
Terry

Re: Desperate for some advice

Posted: Mon Mar 16, 2020 7:16 pm
by nikonwalker
Hi 4D
I did as you suggested , I found a build up of grease on the Z limit across the terminals , cleaned it up and all working great. I am amazed at how something so small created a nightmare for me....
Again thanks

Terry

Re: Desperate for some advice

Posted: Mon Mar 16, 2020 10:13 pm
by 4DThinker
Good to hear, Terry! Glad you got it sorted out.