Troubleshooting Comet

A place to talk about anything that doesn't fit anywhere else.
beltramidave
Posts: 214
Joined: Fri Aug 21, 2015 8:54 pm

Re: Troubleshooting Comet

Postby beltramidave » Tue Dec 08, 2015 4:58 pm

Sorry, I was wrong. :o My fingers must not have typed what my head was thinking.

X, Y1, Y2, Z are used. The axis labeled A is for a lathe attachment. You are correct, you just leave it without anything connected externally. It could be used as a spare if any of the other one would fail.

Glad Probotix got back to you!

beltramidave
Posts: 214
Joined: Fri Aug 21, 2015 8:54 pm

Re: Troubleshooting Comet

Postby beltramidave » Tue Dec 15, 2015 7:27 pm

What about you, Canadian_Comet, did you get back up and running?

Dave

Canadian_Comet
Posts: 15
Joined: Fri Dec 04, 2015 12:37 pm

Re: Troubleshooting Comet

Postby Canadian_Comet » Wed Dec 16, 2015 5:15 pm

Just printing off the conversion for the motors now, fingers crossed all is good after installing the new unit controller so I can get back to working on prototypes.

beltramidave
Posts: 214
Joined: Fri Aug 21, 2015 8:54 pm

Re: Troubleshooting Comet

Postby beltramidave » Wed Dec 16, 2015 6:03 pm

Hope all goes well, let us know,.

Canadian_Comet
Posts: 15
Joined: Fri Dec 04, 2015 12:37 pm

Re: Troubleshooting Comet

Postby Canadian_Comet » Thu Dec 17, 2015 1:13 pm

Well everything works, but the configuration is somehow off.

In the instructions for conversion it says to install a different file ( proboitx Unity Conversion install.zip ) so that is what I used.

Upon start up I find the axis travel at half speed and when it supposed to go 10" it only goes 5"


I called Probotix and they said to use the "machines built in 2015 and on" configuration ( probotix_2015 install.zip )

I am somewhat concerned as to why I would use a configuration different than the Wiki so I thought I would come on here and see if anyone else had the same issues. ( haven't looked yet )

beltramidave
Posts: 214
Joined: Fri Aug 21, 2015 8:54 pm

Re: Troubleshooting Comet

Postby beltramidave » Thu Dec 17, 2015 1:22 pm

I believe that when Len did our conversion that he did make a couple of changes in the config regarding speed, but I don't recall what. If you did talk to Len, he would know. If you didn't talk to Len, call them back and ask for him. He will explain and get you back up and running for sure!

Canadian_Comet
Posts: 15
Joined: Fri Dec 04, 2015 12:37 pm

Re: Troubleshooting Comet

Postby Canadian_Comet » Thu Dec 17, 2015 2:19 pm

Got it figured, wasn't the config files at all.

When I ran EMC2 from the applications it was running the old program, one of the guys told me to go into the home folder, rename EMC2 folder to EMC2_OLD then take the LinuxCNC folder and rename it EMC2 so the application pointed to the "new" program instead of the "old" program.

Also the probotix_2015 install.zip was the wrong one, the fellow who helped me with the rename issue said that config has a different thread pitch on the Z axis and indeed he was right, 1.5" travel showed up as 3" travel.

Reinstalled proboitx Unity Conversion install.zip

Then had to do the rename over again changing the LinuxCNC to EMC2


All seems good, just about to start the prototype case I was working on when the old controller died. Cross my fingers.

Will say the unit behaves differently, so use to the old Unipolar sound and loud controller this new Unity with Bipolar wiring just does not sound right.

Sure I will get use to it and in time forget the old sound, should be good to go, glad the probotix tech was able to identify the problem with the naming of the application folder.

beltramidave
Posts: 214
Joined: Fri Aug 21, 2015 8:54 pm

Re: Troubleshooting Comet

Postby beltramidave » Thu Dec 17, 2015 2:23 pm

Glad you got it figured out. I was comparing the old and new configs and the [Scale] parameters in the .ini files are exactly double of what is in the old .ini file.

Probotix tech support is the best, so don't be afraid to use them when you can't figure it out. I have learned a lot from Len working with my projects!!

Dave


Return to “Open Talk”

Who is online

Users browsing this forum: No registered users and 3 guests