Page 1 of 1

Router gets stuck trying to home X axis

Posted: Sun Nov 15, 2015 5:45 pm
by booktagon
Newb alert.

I recently purchased a V90 Mk2, and I powered it on today. On the "Getting Started" page, I homed, loaded the g-code probotix logo file (or maybe it was pre-loaded) Loaded the toolbit into the spindle. Did the touch off. Verified the spindle was on. Then instead of hitting the "run" button, I started double checking things. I checked my stock placement and what not and then I though to re-do everything just to give myself practice going through the steps. Then I 'experiemented' and clicked the 'load too A button' to see what it would do (I hadn't actually defined the tool bit anywhere, so I though the machine should know what toolbit I had loaded.) Again, newb alert. At any rate, this second time when I clicked the "Home All," the machine homed in on the Y axis but when it started homing on the X axis, it never really stopped.... it reached the limit of the board then tried to keep going.

The motor was going whirrrr whirrrr whirrrrr as the thing tried to home negative X axis, so I clicked the red X and re-booted and tried to re-load and clear out the settings. I ran through the Getting started procedures again, but no luck. During the home all stage, the router attempted to move off the X-axis. On the screen, the X axis was counting negatively, and the little yellow path kept going on the screen as if the router was moving in that direction. Re-boot.

This time I clicked F3 and moved the router to the center. Home All. No luck. Same thing.

Any help would be greatly appreciated.

Re: Router gets stuck trying to home X axis

Posted: Sun Nov 15, 2015 7:14 pm
by booktagon
I do recall that when I was browsing and testing the options that I selected a V90 machine profile -- this profile was, I suppose, different than the one pre-loaded when the CNC Linux first loaded. Perhaps the homing command thinks the machine is wider than it is. I'll try the other machine profiles and make sure I selected the correct one. I believe I selected V90 2015.

More specific details of what is happening during these homing problems

Posted: Sun Nov 15, 2015 9:04 pm
by booktagon
Upon initial turn-on, it homed properly. However, after a re-boot, it won't home properly home on the X axis. Every time I reboot the computer, router, and Linux CNC, the Linux CNC preview pane shows the router spindle to exist in the lower corner of the X-Y axis--when in fact, the router exists in physical space wherever it was when I last turned off the machine. When I attempt to "home all" axes, it properly homes the Y axis but moves up the far-left extreme side of the X axis (which is already the leftmost outer limit of the physical machine) and attempts to move (further) left in the Linux CNC program. When this happens, the machine "whirs" and "chunks" and I have to use the e-stop button.

At this point, I use manual controls to return the router spindle to the middle of the table. But, upon re-boot, the CNC linux shows the spindle to be in the lower-left extreme corner of the X-Y axis.