Page 1 of 1

LinuxCNC homing grief

Posted: Mon Nov 12, 2018 9:22 am
by 4DThinker
Today I can't get our Nebula to home. The first time when Home Machine was clicked on the z axis moved up, came to a stop and generated this error message: "Can't unhome while moving, Z-axis".

Clearing that error, then reconnecting to the controller the Z-axis moves down rather than up when Home Machine is clicked on. The first time it did this I didn't catch it before it drove the 1/8" ball nose bit into the MDF bed until it broke. My E-switch has gotten plenty of use since this started this morning.

I've tried closing then restarting linuxCNC. No change. I've tried restarting the PC, then rerunning linuxCNC. No change. I've tried blowing out the Z axis switch. No change.

The Nebula homed and ran fine Friday 11/9/2018, and has been generally been working fine before that. Not today though.

Any suggestion greatly appreciated. We rely on out Nebula for rotary axis work, and this is a critical time for it to break down.


Re: LinuxCNC homing grief

Posted: Mon Nov 12, 2018 11:36 am
by 4DThinker
I replaced the Z axis switch and all is well again. I believe the old switch had fatigued and wouldn't spring back quick enough again after being hit once during the homing step.

So our Nebula is back in service, at least until the next time a limit switch fails to do its work.


Re: LinuxCNC homing grief

Posted: Sat Nov 24, 2018 1:35 am
by sgano
Thanks for the problem description and update. It will help me (and others) recognize these potential symptoms when the limit switches are going bad.