Page 1 of 1

Y axis limit error

Posted: Fri Apr 19, 2019 7:43 pm
by nickmcc247
This winter while running my comet hard I got a few y limit errors, wouldn’t happen during a program but in between. I restarted, turned off controller and cycled switches on y axis. Got it to work but not sure what was the fix. Later thought it was just cooling down that did the trick. Today I ran a long program and after I got error again, y was far from limit so I let it cool down for a few hours, tried restarting and moving y through the switch manually. Still am getting error after overriding limits and trying to home, will start z then trip y as soon as it hits limit (z limit). Any ideas?

Re: Y axis limit error

Posted: Sat Apr 20, 2019 6:59 pm
by 4DThinker
I'd check the wires connected to the Y limit switches. Those are mounted under the gantry side plates. They may have worked loose from the switch terminals. Anything that causes the limit circuit to open up will throw an error. On our Nebula the X axis switches (mounted on the ends of the gantry beam) started to throw X limit errors whenever we made profile cuts in hardwood and the machine would vibrate a bit. Replacing them and giving the connections a scratch with some sandpaper and a good crimping when attached would stop the problem for awhile. The configurator Probotix provides on their wiki page has an option for "soft limits" that essentially ignores any momentary open circuits vibration caused but still expects the switches to work during homing.

4D