Computer locking up/crashing on my Asteroid

Discuss Machine Mechanics Here
hemicro
Posts: 60
Joined: Fri Aug 21, 2015 12:44 pm

Computer locking up/crashing on my Asteroid

Postby hemicro » Wed Jul 18, 2018 7:58 pm

A couple of weeks ago, my Asteroid starting having some response issues and the computer would become un-responsive. It was intermittent at first, but then it would have issues after every run and I would have to restart the computer by using the power button because normal shutdown would not respond. I finally reinstalled linux and linuxcnc because of the computer behavior and I would see linux doing a hard drive scan/repair on many startups. No help, but I do now have the latest linuxcnc options etc. The amazing thing is what I have found to be the culprit. After hours of frustration I noticed that when the router (Dewalt) was running, I could not access any files or folders. As soon as I turned the router off, the files were accessible. I used a different power cord (I am not using the driver relay), no help. I removed the router from the mount and the problem went away. I held the router against the frame while it was running and the problem was back. I have checked for power isolation on the router. Neither lead indicates continuity to the router body or grounds. I wrapped the body with electrical tape and reinstalled the router and the problem was back. I inadvertently stumbled on a fact that baffles me. The router was running on a speed setting of 4 and if I move the speed to 3 or 5 the problem vanishes. I made many runs today on a speed setting of 5 and everything ran normally. I cannot even imagine why the speed would be a factor or why the computer cannot access files simply because the router is running. I checked the router body (metal on Dewalt) to ground and I do read about 1.9 vac. Its possible there is an insulation breakdown internally I guess. I may have to buy another router to see if that will eliminate the issue. Just thought I would pass on this information in case anyone else runs into this problem or maybe someone has had the problem and has a solution other than purchasing a new router. In any case it may save someone many hours of frustration!!!

o2photo
Posts: 42
Joined: Sat May 07, 2016 1:00 am

Re: Computer locking up/crashing on my Asteroid

Postby o2photo » Wed Jul 25, 2018 8:08 am

When was the last time you changed brushes on it? Probably not the issue, but worth inspecting them.

hemicro
Posts: 60
Joined: Fri Aug 21, 2015 12:44 pm

Re: Computer locking up/crashing on my Asteroid

Postby hemicro » Mon Jul 30, 2018 5:44 pm

I haven't changed the brushes yet, but you're right I should do that, just in case !

4DThinker
Posts: 254
Joined: Wed Oct 07, 2015 10:57 am
Contact:

Re: Computer locking up/crashing on my Asteroid

Postby 4DThinker » Fri Aug 03, 2018 7:22 am

Sounds like you found an EM interference frequency (#4 on your router) that confuses the PC. Any chance you have a WiFi or Bluetooth dongle plugged into the PC , or even wireless mouse or keyboard? I know my old microwave will generate WiFi interference in my house when it runs. I've never had my CNC do what you describe though. No wireless devices on mine though.

4D

o2photo
Posts: 42
Joined: Sat May 07, 2016 1:00 am

Re: Computer locking up/crashing on my Asteroid

Postby o2photo » Fri Aug 03, 2018 7:44 am

Another thought - is there a ferrite core on the cord for the router? Maybe add one regardless if you can't chase the problem down otherwise.

Marc

hemicro
Posts: 60
Joined: Fri Aug 21, 2015 12:44 pm

Re: Computer locking up/crashing on my Asteroid

Postby hemicro » Fri Aug 03, 2018 3:52 pm

I don't have any wireless devices connected, no bluetooth, and no wifi. I will look into the ferrite solution.


Return to “Machine Mechanics”

Who is online

Users browsing this forum: No registered users and 0 guests