Configurator

Discuss software here
hemicro
Posts: 60
Joined: Fri Aug 21, 2015 12:44 pm

Configurator

Postby hemicro » Fri Aug 03, 2018 3:45 pm

Has anyone been able to get the latest configurator to run. When I try to run the probotix.sh file in terminal and I get only a blank screen with a blinking cursor. I had run it in the past, but the updated configurator just won't run. I am trying to add a z puck to my asteroid.

hemicro
Posts: 60
Joined: Fri Aug 21, 2015 12:44 pm

Re: Configurator

Postby hemicro » Fri Aug 10, 2018 2:12 pm

I believe the mystery has been solved. The problem with the configurator occurs after I re-install the .ngc files to the nc_files folder. I have a lot of files that are about 4GB in size. The configurator backs up the files in the nc_files folder and this takes a lot of time. I have left the blank screen run for up to 15 minutes with no results, so I believe the configurator shuts down after a period of time. I have come up with a work around that works for me. I created a folder (nc_design) in the /home/probotix/ folder and loaded all of my .ngc files into this folder. I then edited the .probotix Configuration Settings file in the zipped folder and changed the Program_Prefix to PROGRAM_PREFIX = /home/probotix/nc_design. After editing this line and running a configuration, the cnc program will now look for files in this new folder. This folder is not backed up during configuration so I no longer have a huge nc_files folder, but you must remember that the folder is not backed up. I think this will only be a problem if you re-install the entire system. Kaden at Probotix was helpful in explaining how the configurator works. Hope this helps someone who runs into this problem in the future!


Return to “Software”

Who is online

Users browsing this forum: No registered users and 1 guest